Struts 2
  1. Struts 2
  2. WW-3758

Please update commons-lang dep. to version 3.1

    Details

    • Flags:
      Patch, Important

      Description

      Struts depends on old version of commons-lang package (2.5).
      This package contains class StringEscapeUtils, which contains escapeHtml method.
      This method escapes cyrillic symbols too.
      (In new version commons-lang, which contains escapeHtml3 and escapeHtml4 methods cyrillic not escapes)

      So if I use tags like <s:property value="foo" escapeHtml="true"/> I get html-content with escaped sequence of char like &8231;&1233;&1234 and so on.
      It's makes response body too large for russian-languaged sites.

      1. WW-3631.patch
        70 kB
        Lukasz Lenart

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            Lukasz Lenart
            Reporter:
            Maxim Muslimov
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development