Struts 2
  1. Struts 2
  2. WW-3752

Charset encoding incorrect when using parameters in ServletRedirectResult

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not A Problem
    • Affects Version/s: 2.3.1.1
    • Fix Version/s: 2.3.15
    • Component/s: Dispatch Filter
    • Labels:
      None
    • Environment:

      Tomcat 6

      Description

      See attached test case.

      The issue seems to be that when using some parameters with a ServletRedirectResult, they get encoded twice in UTF-8 : once in UrlHelper.buildParametersString and a second time in response.encodeRedirectURL.

      1. WW-3752.zip
        20 kB
        Denis Cabasson

        Activity

        Denis Cabasson created issue -
        Denis Cabasson added a comment - - edited

        a test case for the issue, based on the struts2-archetype-blank. Just go to http://localhost:8080/WW-3752/example/HelloWorld and follow the 2 links at the bottom. The first one with ASCII parameters works fine, the second not.

        Denis Cabasson made changes -
        Field Original Value New Value
        Attachment WW-3752.zip [ 12513506 ]
        Denis Cabasson made changes -
        Description See attached test case See attached test case.

        The issue seems to be that when using some parameters with a ServletRedirectResult, they get encoded twice in UTF-8 : once in UrlHelper.buildParametersString and a second time in response.encodeRedirectURL.
        Denis Cabasson added a comment -

        Apparently, the bug occurs in Tomcat 6.0.32 (which I am using), but not in jetty 6.1.21. I will upgrade my Tomcat and see if the issue is still there in the latest version of Tomcat.

        Lukasz Lenart made changes -
        Fix Version/s 2.3.7 [ 12323448 ]
        Lukasz Lenart made changes -
        Fix Version/s 2.3.8 [ 12323480 ]
        Fix Version/s 2.3.7 [ 12323448 ]
        Lukasz Lenart added a comment -

        Denis Cabasson any news ?

        Lukasz Lenart made changes -
        Fix Version/s 2.3.9 [ 12323841 ]
        Fix Version/s 2.3.8 [ 12323480 ]
        Lukasz Lenart made changes -
        Fix Version/s 2.3.10 [ 12323903 ]
        Fix Version/s 2.3.9 [ 12323841 ]
        Lukasz Lenart made changes -
        Fix Version/s 2.3.12 [ 12324067 ]
        Fix Version/s 2.3.11 [ 12323903 ]
        Lukasz Lenart made changes -
        Fix Version/s 2.3.13 [ 12324132 ]
        Fix Version/s 2.3.12 [ 12324067 ]
        Lukasz Lenart made changes -
        Fix Version/s 2.3.14 [ 12324256 ]
        Fix Version/s 2.3.13 [ 12324132 ]
        Lukasz Lenart made changes -
        Fix Version/s 2.3.15 [ 12324267 ]
        Fix Version/s 2.3.14 [ 12324256 ]
        Lukasz Lenart added a comment -

        Denis Cabasson please reopen if you disagree

        Lukasz Lenart made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Assignee Lukasz Lenart [ lukaszlenart ]
        Resolution Not A Problem [ 8 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        434d 21h 45m 1 Lukasz Lenart 16/Apr/13 20:11

          People

          • Assignee:
            Lukasz Lenart
            Reporter:
            Denis Cabasson
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development