Struts 2
  1. Struts 2
  2. WW-3656

JQuery-Ajax-Struts2 Validation Plugin- Performance Issue

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Invalid
    • Affects Version/s: 2.2.3
    • Fix Version/s: None
    • Component/s: XML Validators
    • Environment:

      Windows Xp, Glassfish 3.1, Eclipse

    • Flags:
      Patch, Important

      Description

      I am using JQuery-Ajax-Struts2 Validation Plugin for Client side Ajax validation .. i can use the <field-validator type="requied"> type validation in my textfileld.but i m facing problem with <field-validator type="conversion"> type validation. i download the source lib and debug that code. but this code is having some problem with error message. its iterate all the times in some of the IF condition that is not required in some cases. I am Facing Problem that my page is not loaded in Expected time. the problem is if this code is optimize the it will give me some good time to load the page.

      Still my issue is not resolve
      Please refer the Issue
      http://stackoverflow.com/questions/6491442/how-to-validate-a-textfield-for-number-only-in-struts-2

      Thanks in Adv

        Activity

        Dhrumil Shah created issue -
        Dave Newton added a comment -

        Please ask questions on the Struts user mailing list.

        If there's an actual bug, either re-open this ticket, or create a new one.

        Dave Newton made changes -
        Field Original Value New Value
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Invalid [ 6 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Dhrumil Shah
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 72h
              72h
              Remaining:
              Remaining Estimate - 72h
              72h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development