Struts 2
  1. Struts 2
  2. WW-3640

Interceptors should extend AbstractInterceptor

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.3.1
    • Component/s: Core Interceptors
    • Labels:
      None

      Description

      I found a few interceptors that did not extend AbstractInterceptor, so they had (useless) init() and destroy() functions.

        Activity

        John Lindal created issue -
        John Lindal made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Lukasz Lenart made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            John Lindal
            Reporter:
            John Lindal
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development