Uploaded image for project: 'Struts 2'
  1. Struts 2
  2. WW-3528

Move maven dependency junit:junit:3.8.2 from scope 'compile' to scope 'test'

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.2.3
    • Component/s: Build Management
    • Labels:
      None
    • Environment:

      All

    • Flags:
      Important

      Description

      org.apache.struts:struts2-plugins:pom

      adds

      junit:junit:3.8.2

      as a test dependency, but declared the dependency in scope 'compile'.

      all my projects using or referencing struts2-plugins.pom have to exclude the annoying test dependency like this:

      <exclusions>
      <exclusion>
      <groupId>junit</groupId>
      <artifactId>junit</artifactId>
      </exclusion>
      </exclusions>

      i had been troubled by this issue since struts2 2.0.x.

        Attachments

          Activity

            People

            • Assignee:
              maurizio.cucchiara Maurizio Cucchiara
              Reporter:
              rrrrutdk rrrrutdk
            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: