Uploaded image for project: 'Struts 2'
  1. Struts 2
  2. WW-3367

Involve in IDE support for Struts2

    XMLWordPrintableJSON

    Details

    • Type: New Feature
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: Future
    • Fix Version/s: Future
    • Component/s: Other
    • Labels:
      None
    • Environment:

      N/A

      Description

      I believe that productivity is decisive when the time comes for choosing and using any application framework. IDEs greatly improves productivity.

      I'm just evaluating struts2 by now and I use Netbeans. I have found that the only struts2 plugin for NB is not officially supported by the struts2 project (maybe I'm wrong). This plugin is not bad but It may be improved and it may take time to make it compatible with the latest releases of the IDE.

      As a product evaluator it would provide a lot of confidence to me if there were some kind of official involvement between IDE project and framework project in order to have both framework and IDE releases synchronized.

      This cooperation could at least be considered for the most popular ides, like NetBeans and Eclipse.

      I strongly believe this would be a very important point in decision making (for both framework and ide).

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              antodasana Antonio Sánchez
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated: