Struts 2
  1. Struts 2
  2. WW-2098

datetimepicker breaks validation in Firefox

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0.9, 2.0.10
    • Fix Version/s: 2.1.0
    • Component/s: Plugin - Tags
    • Labels:
      None
    • Environment:

      Firexfox 2.0.0.6

      Description

      If I place a requiredstring validator on a datetimepicker then I get the following Javascript popup when the field is not filled in:
      TypeError: row.cells has no properties

        Activity

        James Holmes added a comment -

        Moving to 2.0.11 in preparation for 2.0.10 release.

        Ben McCann added a comment -

        datetimepicker is completely broken in Firefox. Shouldn't this get fixed sooner rather than later? I can't imagine it'd be too hard a fix for someone familiar with the code. I'd be happy to help show the steps needed to reproduce this if needed.

        musachy added a comment -

        Can you provide a section of your jsp? or tell us what theme are you using on your form?

        Ben McCann added a comment -

        I posted a simpler version of my .jsp below.

        <%@ taglib prefix="s" uri="/struts-tags"%>
        <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
        <html>
        <head>
        <title>Add New System</title>
        <s:head />
        </head>
        <body>
        <s:form action="Test" namespace="/admin" validate="true" method="get">
        <span style="font-size:22px; font-weight:bold;">Test</span>
        <s:textfield label="Name" name="name" required="true" />
        <s:datetimepicker label="Date" name="date" required="true" />
        <s:submit cssStyle="margin-right: 450px;" value="Add" />
        </s:form>
        </body>
        </html>

        musachy added a comment -

        it seems to be working fine on 2.1, as there won't be any changes on the ajax theme for the 2.0 family and 2.1 is around the corner I will close this ticket. Feel free to reopen it if you still have a problem on 2.1 but it seems to work for me.

        musachy added a comment -

        It just works on 2.1, not sure if it was a problem that was fixed before or not.

        Ben McCann added a comment -

        Ok. Fair, enough. Any idea on when 2.1 is expected to be released?

        Ben McCann added a comment -

        This issue has not been fixed in 2.1 (WW-2256). It does not work in any version.


          People

          • Assignee:
            musachy
            Reporter:
            Ben McCann
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development