Struts 2
  1. Struts 2
  2. WW-1892

Two tooltips are displayed on IE 7 when using javascript tooltips

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.1.3
    • Component/s: Plugin - Tags
    • Labels:
      None

      Activity

      Hide
      musachy added a comment -

      thanks for the patch!

      Show
      musachy added a comment - thanks for the patch!
      Hide
      Jose Ignacio Gil Jaldo added a comment -

      Hi,

      I've found a similar bug in 2.0.11.1 version. The was in the file template/xhtml/tooltip.ftl.

      The mistake was that thought it takes into account the jsTooltipEnabled in order to render or not the javascript tooltip it does not take into account in order to disable or not the alt property of the image.

      The correct code would be:

      + <#if parameters.jsTooltipEnabled?default('false') == 'false'>
      alt="$

      {parameters.tooltip?html}"
      title="${parameters.tooltip?html}

      "
      + </#if>
      <#t/>/>

      I hope it's useful

      Show
      Jose Ignacio Gil Jaldo added a comment - Hi, I've found a similar bug in 2.0.11.1 version. The was in the file template/xhtml/tooltip.ftl. The mistake was that thought it takes into account the jsTooltipEnabled in order to render or not the javascript tooltip it does not take into account in order to disable or not the alt property of the image. The correct code would be: + <#if parameters.jsTooltipEnabled?default('false') == 'false'> alt="$ {parameters.tooltip?html}" title="${parameters.tooltip?html} " + </#if> <#t/>/> I hope it's useful

        People

        • Assignee:
          musachy
          Reporter:
          musachy
        • Votes:
          1 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development