Struts 2
  1. Struts 2
  2. WW-166

Runtime exception after starting Tomcat

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: WW 2.0-beta1
    • Fix Version/s: None
    • Component/s: XML Configuration
    • Labels:
      None
    • Environment:

      Tomcat 4.1.24

      Description

      If you have deployed an application on Tomcat and run it then restart the server you get a RuntimeException. It's related so Session serialization. There are a couple of work arounds.

      1. Redeploy your application after starting Tomcat.
      2. Erase the SESSIONS.ser file from the application directory in Tomcats work directory.

      java.lang.RuntimeException: Fallback must be an instance of DefaultConfigurationManager
      at com.opensymphony.xwork.interceptor.component.DefaultComponentManager.setFallback(DefaultComponentManager.java:40)
      at com.opensymphony.webwork.lifecycle.RequestLifecycleFilter.doFilter(RequestLifecycleFilter.java:49)

        Issue Links

          Activity

          Maurizio Cucchiara added a comment -

          Please ask this kind of question on the user ML

          insha ali added a comment -

          I am also encountering same sort of problem ... dont know whats the actual cause of this problem....install the tomcat by seeing the tutorial ...then tomcat starts successfully but while running an exception is thrown that is :
          HTTP Status 500 -

          type Exception report

          message

          description The server encountered an internal error () that prevented it from fulfilling this request.

          exception

          org.apache.jasper.JasperException: /search.jsp(151,22) Attribute value language + "/include/header.html" is quoted with " which must be escaped when used within the value
          org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:40)
          org.apache.jasper.compiler.ErrorDispatcher.dispatch(ErrorDispatcher.java:407)
          org.apache.jasper.compiler.ErrorDispatcher.jspError(ErrorDispatcher.java:88)
          org.apache.jasper.compiler.Parser.parseAttributeValue(Parser.java:256)
          org.apache.jasper.compiler.Parser.parseAttribute(Parser.java:205)
          org.apache.jasper.compiler.Parser.parseAttributes(Parser.java:148)
          org.apache.jasper.compiler.Parser.parseInclude(Parser.java:825)
          org.apache.jasper.compiler.Parser.parseStandardAction(Parser.java:1092)
          org.apache.jasper.compiler.Parser.parseElements(Parser.java:1421)
          org.apache.jasper.compiler.Parser.parse(Parser.java:130)
          org.apache.jasper.compiler.ParserController.doParse(ParserController.java:255)
          org.apache.jasper.compiler.ParserController.parse(ParserController.java:103)
          org.apache.jasper.compiler.Compiler.generateJava(Compiler.java:185)
          org.apache.jasper.compiler.Compiler.compile(Compiler.java:354)
          org.apache.jasper.compiler.Compiler.compile(Compiler.java:334)
          org.apache.jasper.compiler.Compiler.compile(Compiler.java:321)
          org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:592)
          org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:328)
          org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:313)
          org.apache.jasper.servlet.JspServlet.service(JspServlet.java:260)
          javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
          note The full stack trace of the root cause is available in the Apache Tomcat/6.0.33 logs.

          please somebody help me asap

          Marc Lehmann added a comment -

          Tomcat 5.0.7 throws the same error while trying to access the designated welcome file (default.jsp) of webwork-example.war (taken from webwork-2.0-beta.zip):

          java.lang.RuntimeException: Fallback must be an instance of DefaultConfigurationManager
          at com.opensymphony.xwork.interceptor.component.DefaultComponentManager.setFallback(DefaultComponentManager.java:50)
          at com.opensymphony.webwork.lifecycle.RequestLifecycleFilter.doFilter(RequestLifecycleFilter.java:54)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
          at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:254)
          at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:151)
          at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:564)
          at org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:256)
          at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:210)
          at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:151)
          at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:564)
          at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:190)
          at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:151)
          at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:175)
          at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:149)
          at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:564)
          at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:156)
          at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:151)
          at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:564)
          at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:974)
          at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:207)
          at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:647)
          at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:489)
          at org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:575)
          at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:649)
          at java.lang.Thread.run(Unknown Source)

          Tracy Snell added a comment -

          You're right! Just tested. Hate when I miss the obvious. Thanks!

          No need for the patch here. Someone can close this issue and I'll open one for xwork to get DefaultComponentManager fixed.

          Low Heng Sin added a comment -

          I think the solution is to make DefaultComponentManager implement serialization.

          Tracy Snell added a comment -

          Still not certain of the cause. However, I think this patch works around the problem for those who need it.

          Tracy Snell added a comment -

          When there is serialized Session data at some point during execution the ServletContext attributes get wiped out. The DefaultComponentManager attribute gets deleted causing the exception when it's later referenced and a null is returned. Still no idea where, I'd tend to think it was a Tomcat issue except for the report of the same issue in WL7.1.

          Tracy Snell added a comment -

          I can't duplicate it on Jetty. There's a report the same error occurs on Weblogic.


            People

            • Assignee:
              Jason Carreira
              Reporter:
              Tracy Snell
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development