Uploaded image for project: 'Struts 2'
  1. Struts 2
  2. WW-1427

struts2-api-2.0.0-SNAPSHOT.pom has servlet-api listed with "compile" scope, should be provided

VotersWatch issueWatchersLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • None
    • 2.0.0
    • XML Configuration
    • None

    Description

      struts2-api-2.0.0-SNAPSHOT.pom has servlet-api listed with "compile" scope, which means it gets included in resulting WARs. I believe this would be better set as <scope>provided</scope>.

      <dependency>
      <groupId>javax.servlet</groupId>
      <artifactId>servlet-api</artifactId>
      <version>2.4</version>
      <scope>provided</scope>
      </dependency>

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            husted Ted Husted
            mraible Matt Raible
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment