Struts 2
  1. Struts 2
  2. WW-1292

DefaultConfiguration swallows caused exception if webwork.properties is malformed

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: WW 2.2.2
    • Fix Version/s: 2.0.0
    • Component/s: XML Configuration
    • Labels:
      None

      Description

      See the WW user forum
      http://forums.opensymphony.com/thread.jspa?messageID=52690&#52690

      public DefaultConfiguration() {
      // Create default implementations
      // Use default properties and webwork.properties
      ArrayList list = new ArrayList();

      try

      { list.add(new PropertiesConfiguration("webwork")); }

      catch (Exception e)

      { log.warn("Could not find webwork.properties"); }

      In the log.war we should at least have e as the cause as 2nd parameter

      Change it to:
      log.warn("Could not find webwork.properties", e);

      And maybe the text "Could not find webwork.properties" should be "Could not find or error in webwork.properties"

        Activity

        Jeff Turner made changes -
        Project Import Mon Feb 01 01:17:42 UTC 2010 [ 1264987062082 ]
        Antonio Petrelli made changes -
        Workflow Struts - editable closed status (temporary) [ 48352 ] Struts - editable closed status [ 51554 ]
        Antonio Petrelli made changes -
        Workflow Struts - editable closed status [ 43964 ] Struts - editable closed status (temporary) [ 48352 ]
        Jeff Turner made changes -
        Workflow Struts [ 40365 ] Struts - editable closed status [ 43964 ]
        Don Brown made changes -
        Workflow jira [ 35275 ] Struts [ 40365 ]
        Rainer Hermanns made changes -
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Closed [ 6 ]
        Rainer Hermanns added a comment -

        Fixed in SVN

        Rainer Hermanns made changes -
        Field Original Value New Value
        Assignee Rainer Hermanns [ rainerh ]
        Fix Version/s 2.0 [ 21510 ]
        Claus Ibsen created issue -

          People

          • Assignee:
            Rainer Hermanns
            Reporter:
            Claus Ibsen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development