Uploaded image for project: 'WSS4J'
  1. WSS4J
  2. WSS-204

Support validating SAML 2.0 tokens

    XMLWordPrintableJSON

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.5.8
    • Fix Version/s: 1.5.9, 1.6
    • Component/s: WSS4J Core
    • Labels:
      None

      Description

      With the patch submitted for Rampart-231, SAML 2.0 support will be available for Rampart. That patch only generates SAML 2.0 tokens as per the SAML Token Profile 1.1 specification. SAML 2.0 validation support is mandatory for the full completion of SAML 2.0 support in Rampart.

        Attachments

        1. wss4j.patch
          22 kB
          Thilina Mahesh Buddhika

          Issue Links

            Activity

              People

              • Assignee:
                coheigea Colm O hEigeartaigh
                Reporter:
                thilinamb Thilina Mahesh Buddhika
              • Votes:
                4 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: