Uploaded image for project: 'Wookie'
  1. Wookie
  2. WOOKIE-383

Redeploying widget without id in config.xml creates new widget

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.13.0
    • Component/s: Wookie REST API
    • Labels:
      None

      Description

      I have a widget without an id in the config.xml. When deploying it to Wookie, it generates an own id.
      The Wookie REST API offers me a redeploying feature by performing an HTTP PUT request on /wookie/widgets/<widgetId> (e.g. /wookie/widgets/http%3A%2F%2Fincubator.apache.org%2Fwookie%2Fgenerated%2FEDB90FB8-C426-601B-8D60-7BDA095AF821 )

      Now when I get the flatpack of the widget, modify it, and redeploy it using the current active widgetId in the URL (which was generated by Wookie), Wookie creates a new widget ID for it, and I have deployed it twice to wookie - with two different IDs. It seems to just deploy it from scratch, ignoring the passed widget ID in the URL.

      I don't know if this behaviour is intended or not but I would like to be able to redeploy a widget without an ID and replace the current one with the new widget file. Again I'm using the latest trunk version.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                sibbl Sebastian M
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: