Wookie
  1. Wookie
  2. WOOKIE-332

wookie php connector relies on file_get_contents which is sometimes disabled

    Details

    • Type: Improvement Improvement
    • Status: Patch Available
    • Priority: Minor Minor
    • Resolution: Unresolved
    • Affects Version/s: 0.9.0, 0.9.1, 0.9.2, 0.10.0, 0.11.0, 0.12.0, 0.13.0
    • Fix Version/s: 2.0.0
    • Component/s: Connection Framework
    • Labels:
    • Environment:
      GNU/Linux 2.6.32-220.2.1.el6.x86_64
      php5
      elgg platform

      Description

      Since a few weeks ago our server admin disabled php's function
      file_get_contents (for security reasons) which resulted for our elgg
      plugin not to work.

      I did a quick goole search and found that disabling file_get_contents
      is quite usual in virtual servers setups - dreamhost for example has
      it locked.
      In the other hand curl might not be enabled as well but i guess is
      more likely for file_get_contents to be unavailable instead of curl

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            Kris Popat
            Reporter:
            Lucas Anastasiou
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:

              Development