Uploaded image for project: 'Wookie'
  1. Wookie
  2. WOOKIE-325

Add a "validate package" feature to the wookie rest api

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.10.0
    • Fix Version/s: 0.12.0
    • Component/s: Wookie REST API
    • Labels:
      None
    • Environment:
      n/a

      Description

      This feature would allow a calling application to POST a widget to wookie and receive its metadata back in response. (WOOKIE-324). The package is parsed to make sure it conforms to the spec & also make sure that its valid. However, the package is not made available as a widget (you can't instantiate it) and the widget objects & resources themselves are destroyed afterwards. This service could possibly be open to all users, not just admin. We would be essentially exposing the parser mechanism as an additional rest service.

        Attachments

          Activity

            People

            • Assignee:
              psharples Paul Sharples
              Reporter:
              psharples Paul Sharples
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: