Wookie
  1. Wookie
  2. WOOKIE-167

Gallery icons for bondi camera & geolocation are missing

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 0.9.0
    • Fix Version/s: 0.10.0
    • Component/s: Server
    • Labels:
      None
    • Environment:
      Win Vista (IE8 and Firefox 3.6.12)

      Description

      To reproduce...

      (1) Start wookie in standalone mode
      (2) Go to http://localhost:8080/wookie
      (3) Click 'view widget gallery'
      (4) Notice the icons for 'camera' and 'geo' widgets

      Tried this with both IE8 and firefox 3.6.12 and these two widgets have their icons missing in the gallery. Interestingly, google chrome is unaffected.

        Activity

        Paul Sharples created issue -
        Scott Wilson added a comment -

        Its due to the fact that the icons for these two widgets are in SVG format.

        It turns out to be simply that Firefox's implementation of SVG doesn't (yet) extend to the <img> tag. It only works using <object>. However, given that Safari and Chrome et al support it I guess its just a matter of time before FF's SVG implementation catches up.

        As for IE, it just doesn't support SVG. At all.

        The W3C spec itself recommends SVG for icons as they can scale nicely for any sort of gallery, which is a good reason to use them, but maybe we have to use a fallback trick for IE and FF, as described here:

        http://e.metaclarity.org/52/cross-browser-svg-issues/

        Scott Wilson made changes -
        Field Original Value New Value
        Status Ready To Review [ 10006 ] Open [ 1 ]
        Fix Version/s 0.9.1 [ 12315418 ]
        Fix Version/s 0.9.0 [ 12315417 ]
        Scott Wilson added a comment -

        Moving to 0.9.2

        Scott Wilson made changes -
        Fix Version/s 0.9.2 [ 12315419 ]
        Fix Version/s 0.9.1 [ 12315418 ]
        Scott Wilson made changes -
        Fix Version/s 0.9.3 [ 12318245 ]
        Fix Version/s 0.9.2 [ 12315419 ]
        Scott Wilson made changes -
        Fix Version/s 1.0.0 [ 12319085 ]
        Fix Version/s 1.1.0 [ 12318245 ]
        Scott Wilson added a comment -

        Added .png icons

        Scott Wilson made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Paul Sharples added a comment -

        Verified

        Paul Sharples made changes -
        Status Closed [ 6 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Reviewable Reviewable Open Open
        1d 1h 59m 1 Scott Wilson 29/Nov/10 16:32
        Open Open Closed Closed
        460d 2h 14m 1 Scott Wilson 03/Mar/12 18:46
        Closed Closed Resolved Resolved
        71d 20h 35m 1 Paul Sharples 14/May/12 16:21

          People

          • Assignee:
            Unassigned
            Reporter:
            Paul Sharples
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development