Uploaded image for project: 'Wookie'
  1. Wookie
  2. WOOKIE-115

Incorrect widget build file prevents Wookie from starting in dev mode

    Details

    • Type: Bug
    • Status: Open
    • Priority: Trivial
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: 2.0.0
    • Component/s: Documentation
    • Labels:
      None
    • Environment:
      Ubuntu Linux running sun-java-6. Running Wookie in standalone mode for development.

      Description

      I installed a widget (specifically, Scott's example todo widget) through the admin interface with the .wgt file.
      After using it and displaying it on a Moodle page with the plugin, I used the admin interface to delete the widget.
      After deleting the widget, any attempt to access the Widget gallery resulted in an HTTP 500 error.
      When attempting to close and restart the server, the following error was displayed, and the server wouldn't start:

      BUILD FAILED
      /home/mark/public_html/wookie/wookie/ant/ivy-webapp-common.xml:45: The following error occurred while executing this line:
      /home/mark/public_html/wookie/wookie/build.xml:45: The following error occurred while executing this line:
      /home/mark/public_html/wookie/wookie/widgets/build.xml:71: /home/mark/public_html/wookie/wookie/widgets/todo not found.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                marxjohnson Mark Johnson
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated: