Woden
  1. Woden
  2. WODEN-16

When message content model is #none, Woden emits an invalid <elementDeclaration ref="id-null"/> reference.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Parser
    • Labels:
      None

      Description

      This problem was described by Jonathan Marsh in a post to the W3C WSDL working group [1].

      When message content model is #none, Woden emits an invalid <elementDeclaration ref="id-null"/> reference.

      John, sounds to me like this falls under the resposibility of the parser. Feel free to reassign if I'm incorrect.

      [1] http://lists.w3.org/Archives/Public/www-ws-desc/2006May/0074.html

        Activity

        Lawrence Mandel created issue -
        Lawrence Mandel made changes -
        Field Original Value New Value
        Component/s Parser [ 12311157 ]
        Arthur Ryman made changes -
        Assignee John Kaputin [ jkaputin ] Arthur Ryman [ ryman ]
        Arthur Ryman added a comment -

        I assigned this to myself since Jonathan is seeing the result of the component model interchange format output. I'll diagnose the cause.

        Arthur Ryman added a comment -

        I fixed the Ant task to check for OPTIONAL references.

        Arthur Ryman made changes -
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        John Kaputin added a comment -

        Arthur, I think Lawrence opened this JIRA at your request, Can we close it now?

        Arthur Ryman added a comment -

        Closing.

        Arthur Ryman made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Arthur Ryman
            Reporter:
            Lawrence Mandel
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development