Wink
  1. Wink
  2. WINK-300

Update Spring version to 3.0 or change spring dependency scope 'provided'

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.1.1
    • Fix Version/s: 1.2
    • Component/s: Spring
    • Labels:
      None

      Description

      Currently the spring-support module depends on the aggregated jar of 2.5.
      However, since 3.0, Spring doesn't provides an aggregated jar anymore.
      So, when running with 3.0 and Wink, all spring jars must be specified and 2.5 aggregated jar must be excluded.

      There are two possible fixes:
      1. Mark Spring dependency as 'provided'. This will eliminate the exclude, but will force to specify the spring dependency manually, which is ok, since none should be using the spring-support module without using spring by himself.

      2. Specify the concrete dependency (spring-context, spring-core, anything else?) instead of the aggregated jar.

      Let me know what do you think about these options. Personally I prefer option 2 and also moving to Spring 3.0.

        Activity

          People

          • Assignee:
            Unassigned
            Reporter:
            Michael Elman
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development