Wicket
  1. Wicket
  2. WICKET-976

IndexedParamUrlCodingStrategy chokes inside appendParameters() on Stateless forms

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.3.0-beta3
    • Fix Version/s: 1.3.0-beta4
    • Component/s: wicket
    • Labels:
      None

      Description

      Please see this thread - http://www.nabble.com/Bug-in-IndexedParamUrlCodingStrategy-1.3-Beta3-tf4440109.html#a12669595 .

      The issue is when ever i use the IndexParamUrlCodingStrategy on a page that contains a Stateless form, the following error occurs:

      [RequestCycle] Not all parameters were encoded. Make sure all parameter names are integers in consecutive order starting with zero. Current parameter names are: [wicket:interface]
      org.apache.wicket.WicketRuntimeException: Not all parameters were encoded. Make sure all parameter names are integers in consecutive order

      The issue seems to be that the pagemap is null and the Map parameters that are passed are not able to be parsed.

        Activity

        chris lintz created issue -
        Johan Compagner added a comment -

        fixed with the improved stateless forms and coding strategies fix

        Johan Compagner made changes -
        Field Original Value New Value
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Fix Version/s 1.3.0-beta4 [ 12312680 ]
        Assignee Johan Compagner [ jcompagner ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        18d 23h 37m 1 Johan Compagner 03/Oct/07 16:53

          People

          • Assignee:
            Johan Compagner
            Reporter:
            chris lintz
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development