Uploaded image for project: 'Wicket'
  1. Wicket
  2. WICKET-932

BaseWicketTester support for SubmitLink

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.3.0-beta2
    • Fix Version/s: 1.3.3
    • Component/s: wicket-extensions
    • Labels:
      None
    • Environment:
      XP, Tomcat

      Description

      When the SubmitLink is used instead of the submit for forms, BaseWicketTester does not run through the onSubmit() code of the link.

      I have stepped through the debug of the test that's actually not getting called. All my validators on the text field are getting called as expected and in fact the form works as expected when deployed so I'm thinking that it might be a WicketTester issue or the more likely scenario that I'm doing something wrong?

      Things I've tried:

      • debugging as mentioned, but this just shows me it's not getting called
      • trying to call the link directly but I just get the below exception which I'm not really surpised about....

        Attachments

        1. JIRA932.zip
          2 kB
          Simon Comley

          Activity

            People

            • Assignee:
              frankbille Frank Bille Jensen
              Reporter:
              cruiserdude Simon Comley
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: