Wicket
  1. Wicket
  2. WICKET-694

getMarkupId doesn't return the id from the markup when it is explicitly set

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.3.0-beta1
    • Fix Version/s: None
    • Component/s: wicket
    • Labels:
      None

      Activity

      Hide
      Eelco Hillenius added a comment -

      It's just not feasible without the constructor change (which had too many other side effects). We'll just have to live with not getting the id from markup automatically. Instead, as an ultimate breakout, people can read the id themselves and explicitly set it. I think we should just keep it at this and regard this issue as 'would've been nice, but alas'.

      Show
      Eelco Hillenius added a comment - It's just not feasible without the constructor change (which had too many other side effects). We'll just have to live with not getting the id from markup automatically. Instead, as an ultimate breakout, people can read the id themselves and explicitly set it. I think we should just keep it at this and regard this issue as 'would've been nice, but alas'.
      Hide
      Eelco Hillenius added a comment -

      See also WICKET-614

      Show
      Eelco Hillenius added a comment - See also WICKET-614
      Hide
      Eelco Hillenius added a comment -

      The fix had unforseen side effects. Rolling that back.

      Show
      Eelco Hillenius added a comment - The fix had unforseen side effects. Rolling that back.

        People

        • Assignee:
          Eelco Hillenius
          Reporter:
          Eelco Hillenius
        • Votes:
          0 Vote for this issue
          Watchers:
          1 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development