Uploaded image for project: 'Wicket'
  1. Wicket
  2. WICKET-6609

Update Guice from 4.1.0 to 4.2.2

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 8.1.0
    • Fix Version/s: 8.2.0, 9.0.0-M1
    • Component/s: wicket-guice
    • Labels:
      None

      Description

      Google Guice 4.2.2 has been released recently. Wicket 8.1.0 still uses 4.1.0 which is binary compatible so we should upgrade.

        Attachments

          Activity

            People

            • Assignee:
              mgrigorov Martin Tzvetanov Grigorov
              Reporter:
              mgrigorov Martin Tzvetanov Grigorov

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment