Uploaded image for project: 'Wicket'
  1. Wicket
  2. WICKET-6401

OSGi-Manifest: wicket-util should decalre its dependency to 'commons-io' and 'commons-fileupload'

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Resolved
    • Minor
    • Resolution: Fixed
    • 7.7.0
    • 7.8.0, 8.0.0-M7
    • wicket
    • None

    Description

      Wicket-Util has no import-package declaration for the static used imports to commons-io (e.g. in FileCleaner) and commons-fileupload.
      Currently the bundle simply fails if the requirement is not fullfiled with ClassNotFoundException on Application start-up.

      Attachments

        Issue Links

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            mgrigorov Martin Tzvetanov Grigorov
            laeubi Christoph Läubrich
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment