Wicket
  1. Wicket
  2. WICKET-5418

PropertyValidator ignoring groups with the @NotNull annotation only

    Details

      Description

      When using groups in your JSR303 compliant classes, Wicket does not honor the groups for the @NotNull annotation.

      1. BeanValidation.zip
        28 kB
        Jesus Mireles

        Activity

        Jesus Mireles created issue -
        Jesus Mireles added a comment -

        An example with groups

        Jesus Mireles made changes -
        Field Original Value New Value
        Attachment BeanValidation.zip [ 12613735 ]
        Martin Grigorov made changes -
        Priority Critical [ 2 ] Major [ 3 ]
        Martin Grigorov added a comment -

        I had the good willing to debug this problem but you work against yourself.
        1) you removed Start.java from the quickstart so it is harder for me to debug it
        2) your quickstart doesn't use any bean validation impl
        Caused by: javax.validation.ValidationException: Unable to find a default provider
        at javax.validation.Validation$GenericBootstrapImpl.configure(Validation.java:264)
        at org.apache.wicket.bean.validation.DefaultValidatorProvider.get(DefaultValidatorProvider.java:29)
        at org.apache.wicket.bean.validation.DefaultValidatorProvider.get(DefaultValidatorProvider.java:19)

        I can fix both of these but I see no reason why you tried to make it harder for us.

        Please provide a proper quickstart with steps how to reproduce your problem.

        Martin Grigorov made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Igor Vaynberg [ ivaynberg ]
        Resolution Fixed [ 1 ]
        Martin Grigorov made changes -
        Resolution Fixed [ 1 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        Martin Grigorov made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Resolution Incomplete [ 4 ]
        Jesus Mireles made changes -
        Attachment BeanValidation.zip [ 12613735 ]
        Jesus Mireles added a comment - - edited

        Quickstart to reproduce issue. Sorry Martin, I dont know what happend but I uploaded the wrong quickstart. I fixed and added a few clarifications in the homepage.html

        Jesus Mireles made changes -
        Attachment BeanValidation.zip [ 12614083 ]
        Igor Vaynberg made changes -
        Assignee Igor Vaynberg [ ivaynberg ]
        Igor Vaynberg made changes -
        Resolution Incomplete [ 4 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        Igor Vaynberg made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Fix Version/s 6.13.0 [ 12325564 ]
        Fix Version/s 7.0.0 [ 12322958 ]
        Resolution Fixed [ 1 ]

          People

          • Assignee:
            Igor Vaynberg
            Reporter:
            Jesus Mireles
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development