Wicket
  1. Wicket
  2. WICKET-5400

Behaviors#internalAdd(Behavior) erroneously gets id for stateless behaviors

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 6.11.0, 7.0.0-M1
    • Fix Version/s: 6.13.0, 7.0.0-M1
    • Component/s: wicket
    • Labels:
      None

      Activity

      Martin Grigorov added a comment -

      Cool.
      I will release WicketStuff 6.13 early next week. There were few reports for regression in Wicket 6.13 and I want to see whether there will be 6.13.1 or not.

      Rob Sonke added a comment - - edited

      Ah, thanks a lot. I didnt notice that change. I'll check it right away!

      Edit: Works like a charm!

      Martin Grigorov added a comment -

      https://github.com/wicketstuff/core/tree/master/jdk-1.6-parent/stateless-parent has changed too - https://github.com/wicketstuff/core/commit/ecadd460a17387fef7399223137f5fa1e86d5a32.

      I have tested the change against 6.13.0-SNAPSHOT at the time.
      Please try with Wicket 6.13.0 and WicketStuff 6.0-SNAPSHOT and if it breaks then create an issue for WicketStuff with more detailed description.
      Thanks!

      Rob Sonke added a comment -

      Could it be that this has broken the implementation of WICKET-3764? I'm checking this but since wicket 6.13 I'm getting the error from WICKET-3764 again.

      Sven Meier added a comment -

      Yes, I think this is a minor issue only: We're wasting a few bytes for behavior-ids which are not needed. The misleading error message in our tests is just a small trouble.

      Martin Grigorov added a comment -

      By prio "Minor" do you say it is OK to leave that change after the release of 6.12 ?
      I prefer to do it after 6.12 is out so we have more time to test it for 6.13.

      I have no idea when 6.12 will be released though.


        People

        • Assignee:
          Martin Grigorov
          Reporter:
          Sven Meier
        • Votes:
          0 Vote for this issue
          Watchers:
          4 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development