Wicket
  1. Wicket
  2. WICKET-526

URL mounting doesn't work well together with stateless pages

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.0-beta1
    • Fix Version/s: 1.3.0-beta2
    • Component/s: wicket
    • Labels:
      None

      Description

      See the stateless example. Uncomment the mount line in StatelessApplication#init, and test the form in the example. When it is not mounted, it displays feebback, when it's mounted it doesn't.

        Issue Links

          Activity

          Eelco Hillenius added a comment -

          Not only feedback, anything that depends temporary state will break with redirects

          Alastair Maw added a comment -

          Looks like it needs fixing for 1.3.0.

          Eelco Hillenius added a comment -

          There is currently even more broken. If you do uncomment that line and test the stateless example, and submit the form in the 'other' stateless page, you'll see that the reference to the stylesheet is wrong as well. The proper one (as it is before the form submit) is:
          <link href="../../style.css" rel="stylesheet" type="text/css"/> and the URL to the page is: http://localhost:8080/wicket-examples/stateless/public/StatelessPage

          After the commit this is:
          <link href="../../../../../../../../style.css" rel="stylesheet" type="text/css"/> for URL:
          http://localhost:8080/wicket-examples/stateless/public/StatelessPage/wicket:interface/%3A0%3Astatelessform%3A%3AIFormSubmitListener%3A%3A

          Eelco Hillenius added a comment -

          Ok, that last issue was unrelated and is fixed now.

          Eelco Hillenius added a comment -

          Turned out to have nothing to do with state, but rather with the way mounts were handled (package mounts ignored the interface parameter that is used for requests to stateless pages).

          Eelco Hillenius added a comment -

          It was actually only partially a duplicate of WICKET-497, as part of the problem was that the package mounter didn't look for the interface argument to decide what request target to return.


            People

            • Assignee:
              Eelco Hillenius
              Reporter:
              Eelco Hillenius
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development