Wicket
  1. Wicket
  2. WICKET-4571

UrlRenderer renders invalid full URLs with CryptoMapper

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: 1.5.6
    • Fix Version/s: None
    • Component/s: wicket
    • Labels:
      None
    • Environment:
      Windows 7 64-bit, WebSphere 7.0.0.21, JDK 1.6.0_29

      Description

      Letting UrlRenderer render full URL for a listener (for example) and having CryptoMapper enabled, results in an invalid URL rendered. This might relate to WICKET-4514 where rendering of URLs was affected.

      In my code i need to get absolute (full, with scheme, host, etc.) URL for some listener:

      Url listenerUrl = requestCycle.mapUrlFor(new ListenerInterfaceRequestHandler(new PageAndComponentProvider(getPage(), this), INTERFACE));
      String url = requestCycle.getUrlRenderer().renderFullUrl(listenerUrl);

      When debugging I noticed following:
      url parameter (passed to UrlRenderer#renderFullUrl): D05Y_Hf6Gtcqg5StYqh73OMUH2yY_Ps5aoSZiIDSpe-1BsyiT6gVwPICMDN9hWrzYqNMxKrInNA/D05f8/zYqb1
      baseUrl (member variable of UrlRenderer): D05Y_Hf6GtecWD_aOClIdg/D05f8/dgD40
      after calling base.resolveRelative in else block of UrlRenderer#renderFullUrl: D05Y_Hf6GtecWD_aOClIdg/D05f8/D05Y_Hf6Gtcqg5StYqh73OMUH2yY_Ps5aoSZiIDSpe-1BsyiT6gVwPICMDN9hWrzYqNMxKrInNA/D05f8/zYqb1 - THIS URL IS INVALID AN RESULTS IN HTTP/404 ERROR

        Activity

        Martin Grigorov added a comment -

        Duplicate of WICKET-4561.


          People

          • Assignee:
            Unassigned
            Reporter:
            David Rain
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development