Wicket
  1. Wicket
  2. WICKET-4291

Problem in Chrome when adding panel with modal windows to ajax request target

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.5.3
    • Fix Version/s: None
    • Component/s: wicket, wicket-extensions
    • Labels:
      None
    • Environment:
      Chromium 8.0 & Ubuntu 10/10

      Description

      When trying to replace an empty panel with one that contains a modal window during an AJAX request the DOM insn't modified. The wicket ajax debug windows shows that the request is being made and the answert, but when trying to apply the changes to the DOM the debug windows hangs after this message: "INFO: Response parsed. Now invoking steps...". If I press F5 to refresh, the chages are shown indicating that the request was processed correctly and the changes in the page hierarchy were persisted. However if I click again in the link that fires the ajax request the wicket debug windows shows this message: "INFO: Channel busy - postponing...".

      We couldn't reproduce this issue in firefox. I'll attach a quickstart for reproducing the problem. When running it locally if I click in the link the DOM isn't updated as suppossed to.

      1. sga-ajaxqs.zip
        27 kB
        Martín Bigio

        Activity

        Martin Grigorov added a comment -

        Your app behaves the same way in Chrome 17.x and Firefox 8.
        The EmptyPanel is replaced with SimplePanel without any problems. Since there is no code that calls modalWindow.show(target) the modal itself is never shown.

        I needed to recreate the quickstart because your attachment was broken somehow...


          People

          • Assignee:
            Unassigned
            Reporter:
            Martín Bigio
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development