Wicket
  1. Wicket
  2. WICKET-4178

Use a strategy to decide how much information to log when a thread cannot get the lock to a page

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.5.2
    • Fix Version/s: 1.5.3
    • Component/s: wicket
    • Labels:
      None

      Description

      In Wicket 1.4.x, the pagemap would also log the stacktrace for threads that hold the pagelock, if a timeout occurs. This behaviour is no longer present in 1.5.x.

        Issue Links

          Activity

          Emond Papegaaij added a comment -

          This patch reintroduces the old behaviour

          Martin Grigorov added a comment -

          Duplicate of WICKET-4170.

          Martin Grigorov added a comment -

          Reopening: We will improve the configuration to be able to specify what info to dump additionally: NOTHING, ONE_THREAD (the one that holds the lock) and ALL (full thread dump).

          Martin Grigorov added a comment -

          With r1190198 it is possible to define a strategy how much info to dump when a thread cannot get the lock for a page for the configured timeout duration.
          By default only the stacktrace of the thread that holds the lock is dumped but it is also possible to dump all or none threads.

          Thanks Emond!


            People

            • Assignee:
              Martin Grigorov
              Reporter:
              Emond Papegaaij
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development