Wicket
  1. Wicket
  2. WICKET-3856

Relax wicket:enclosure warning suggesting the usage of EnclosureContainer

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.4.18
    • Component/s: wicket
    • Labels:
      None

      Description

      Sometime in 1.4, wicket:enclosure got some diagnostics warnings about FormComponents and EnclosureContainer was added.

      wicket:enclosure has two usages:

      ---------------
      1) Hide some content based on its own child components, i.e.:

      <wicket:enclosure child="x">
      <div>
      ........
      <input wicket:id="x" />
      </div>
      </wicket:enclosure>

      2) Hide content based on non-child components, i.e.:

      <wicket:enclosure child="x">
      ........
      </wicket:enclosure>
      <input wicket:id="x" />
      ---------------

      It's safe to relax the warning for the case (1), when the only FormComponent child is equal to the "wicket:enclosure child" attribute.

        Activity

        Adriano dos Santos Fernandes added a comment -

        Are you going to fix it in 1.5-RC6 too?

        Juergen Donnerstag added a comment -

        It shouldn't exist in 1.5 trunk. Please test.

        Adriano dos Santos Fernandes added a comment -

        Was it fixed in some other way?

        The issue is present in 1.5-RC5.1, and I don't see the same commit in trunk's Enclosure.java.

        Juergen Donnerstag added a comment -

        yes

        Juergen Donnerstag added a comment -

        sorry. The patch has been attached to WICKET-3789, but I did not commit it yet. Will do so soon.


          People

          • Assignee:
            Igor Vaynberg
            Reporter:
            Adriano dos Santos Fernandes
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development