Wicket
  1. Wicket
  2. WICKET-35

WicketTester doesn't pass PageParameters to bookmarkable pages

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0 branch (discontinued), 1.2.2, 1.2.3
    • Component/s: wicket
    • Labels:
      None

      Description

      I put BookmarkablePageLink on WebPage like this:
      firstPage.add( new BookmarkablePageLink( "link", SecondPage.class, new
      PageParameters( "id=1" ) ) );

      and then I test it using WicketTester:
      wicketTester.startPage( FirstPage.class );
      wicketTester.clickLink( "link" );

      The problem is that wicketTester doesn't pass PageParameters to SecondPage
      (because parameters aren't passed to MockHttpServletRequest).

        Activity

        Frank Bille Jensen added a comment -

        confirmed

        Frank Bille Jensen added a comment -

        Fixes are in the 1.x branch and 2.0. Can you please confirm them and then close this issue?

        1.x: http://svn.apache.org/viewvc?view=rev&revision=471275
        2.0: http://svn.apache.org/viewvc?view=rev&revision=471276

        Frank Bille Jensen added a comment -

        Fix confirmed by reporter.


          People

          • Assignee:
            Frank Bille Jensen
            Reporter:
            Dmitry Kandalov
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development