Wicket
  1. Wicket
  2. WICKET-3333

Links with multiple parameters are wrongly generated

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.5-RC1
    • Fix Version/s: 1.5-RC1
    • Component/s: wicket
    • Labels:
      None

      Description

      If you have a PageParameters, with multiple params, then the resulting link will be something like this /url?id=123&sid=456, so for some reason the & sign is encoded to & which will result in the following parameters on the receiving page:
      id=[123], amp;sid=[456]
      See the attached quickstart for example.

        Issue Links

          Activity

          Hide
          Martin Grigorov added a comment -

          With r1059051 this problem is fixed.
          But there are some more candidates for the same problem.

          Show
          Martin Grigorov added a comment - With r1059051 this problem is fixed. But there are some more candidates for the same problem.
          Hide
          Peter Major added a comment -

          Quickstart app demonstrating the problem.

          Show
          Peter Major added a comment - Quickstart app demonstrating the problem.

            People

            • Assignee:
              Martin Grigorov
              Reporter:
              Peter Major
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development