Wicket
  1. Wicket
  2. WICKET-3141

On multipart form, sendRedirect() with PageParameters are not working

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.4.12
    • Fix Version/s: 1.4.14, 1.5-RC1
    • Component/s: wicket
    • Labels:
      None

      Description

      On a multipart form, calling setResponsePage(Class, PageParameters) will not redirect to the requested page.
      In the wicket ajax debug the following error appears:

      INFO: focus set on save3
      INFO: Invoking pre-call handler(s)...
      ERROR: Wicket.Ajax.Call.failure: Error while parsing response: Could not find root <ajax-response> element
      INFO: Invoking post-call handler(s)...
      INFO: Invoking failure handler(s)...

      and in Firefox Error Console the following error appears:

      Error: not well-formed
      Source File: http://localhost:8080/sample/?wicket:interface=:0:form:save::IActivePageBehaviorListener:0:1&wicket:ignoreIfNotActive=true&wicket:ajax=true
      Line: 1, Column: 87
      Source Code:
      <ajax-response><redirect>../?wicket:bookmarkablePage=:problem.sample.SecondPage&param1=value1&param2=value2</redirect></ajax-response>

      The problem is, that the URL from the response XML are not xml encoded.

      1. sample.zip
        12 kB
        Fulop Levente

        Activity

        Fulop Levente added a comment -

        Attached a sample application.

        Martin Grigorov added a comment -

        Fixed with r1029411 (1.5-SNAPSHOT) and r1029412 (1.4.x)

        Hudson added a comment -

        Integrated in Apache Wicket 1.5.x #473 (See https://hudson.apache.org/hudson/job/Apache%20Wicket%201.5.x/473/)
        WICKET-3141 On multipart form, sendRedirect() with PageParameters are not working

        Wrap the 'redirect to' URL in the Ajax response in CDATA to be able to handle properly unencoded XML

        Hudson added a comment -

        Integrated in Apache Wicket 1.4.x #242 (See https://hudson.apache.org/hudson/job/Apache%20Wicket%201.4.x/242/)


          People

          • Assignee:
            Martin Grigorov
            Reporter:
            Fulop Levente
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development