Uploaded image for project: 'Wicket'
  1. Wicket
  2. WICKET-3040

Ajax form submit fails in Wicket 1.4.11/Firefox3.6

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.4.11, 1.5-M2.1
    • Fix Version/s: 1.4.12, 1.5-M2.1
    • Component/s: wicket
    • Labels:
      None
    • Environment:
      Wicket 1.4.11, Firefox 3.6.10pre

      Description

      The very first ajax form submit fails in the attached quickstart.
      The cause is :
      Revision 988809 - (view) (download) (as text) (annotate) - [select for diffs]
      Modified Wed Aug 25 05:22:58 2010 UTC (2 weeks, 2 days ago) by ivaynberg
      AjaxSubmitLink not calling the onsubmit event handler
      Issue: WICKET-2807

      commenting wicket-ajax.js, line 1096:
      submitForm: function(form, submitButton) {
      if (!Wicket.Event.fire(form, "submit")) return; <<<<<< THIS
      if (this.handleMultipart(form, submitButton)) {
      fixes the problem

      1. wicket-3040.tgz
        5 kB
        Martin Grigorov

        Issue Links

          Activity

          mgrigorov Martin Grigorov added a comment -

          Attaching a quickstart.
          Ignore the odd way java and html are placed.
          The very first click on the link at: http://localhost:8080/pack/OtherPage doesn't work, all following click work.

          ivaynberg Igor Vaynberg added a comment -

          is this also failing in 1.5-m2? if so we should -1 the release.

          mgrigorov Martin Grigorov added a comment -

          Nino's mail is about 1.5-m2. I'll check it later

          hudson Hudson added a comment -

          Integrated in Apache Wicket 1.4.x #158 (See https://hudson.apache.org/hudson/job/Apache%20Wicket%201.4.x/158/)
          WICKET-3040 Ajax form submit fails in Wicket 1.4.11/Firefox3.6

          Do not fire form.submit() because this makes normal (non-ajax) call and calls just Form.onSubmit().
          Just call form.onsubmit() if there is such and do not do anything if it returns negative result

          hudson Hudson added a comment -

          Integrated in Apache Wicket 1.5.x #324 (See https://hudson.apache.org/hudson/job/Apache%20Wicket%201.5.x/324/)
          WICKET-3040 Ajax form submit fails in Wicket 1.4.11/Firefox3.6

          Do not fire form.submit() because this makes normal (non-ajax) call and calls just Form.onSubmit().
          Just call form.onsubmit() if there is such and do not do anything if it returns negative result

          merge r996157 from wicket 1.4.x


            People

            • Assignee:
              mgrigorov Martin Grigorov
              Reporter:
              mgrigorov Martin Grigorov
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development