Wicket
  1. Wicket
  2. WICKET-2868

problem with AbstractDefaultAjaxBehavior in Internat Explorer

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.4.8
    • Fix Version/s: None
    • Component/s: wicket
    • Environment:
      Microsoft XP, IE8

      Description

      add(new AbstractDefaultAjaxBehavior(){
      @Override
      protected void respond(AjaxRequestTarget target)

      { System.out.println("test"); }

      @Override
      public void renderHead(final IHeaderResponse response)

      { super.renderHead(response); handleCallbackScript(response, getCallbackScript().toString()); }

      protected void handleCallbackScript(final IHeaderResponse response, final
      String callbackScript)

      { response.renderOnDomReadyJavascript(callbackScript); }


      });

      Hi, i am using AbstractDefaultAjaxBehavior and it's not working properly in IE8,
      in IE8 respond(AjaxRequestTarget target) method does not execute but in Mozilla frefox, it's working fine

        Activity

        Martin Grigorov added a comment -

        Is there any chance that you actually use IE9 ?
        Because I noticed that IE9 has improvements in that area and the code in Wicket that sniffs what is the browser thinks it is actually Gecko based one and later fails.

        If it is IE8 then please create a quickstart application that reproduces the problem so the developers could test it sooner.
        Looking at the code snippet I could say that I use this in many places in my applications and I can confirm that it works on IE8.

        Kailash Yadav added a comment -

        It's working with quickstart application but still not working in my application , i have to investigate in my application for fix it.
        I am closing this issue.
        thanks


          People

          • Assignee:
            Unassigned
            Reporter:
            Kailash Yadav
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development