Wicket
  1. Wicket
  2. WICKET-271

investigate Ajax back button support

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: wicket
    • Labels:
      None

      Description

      Investigate what we can do to support the back button with Ajax. Currently, we don't support versioning with Ajax, so the back button always takes you back to the location before the ajax calls.

      See discussion here: http://www.nabble.com/Single-page-applications%3A-bad-idea-in-Wicket---tf3182341.html

        Issue Links

          Activity

          Eelco Hillenius added a comment -

          If I understand correctly, Johan did some work on the server side to support this. So what we would need next is someone to think up some JavaScript foo. Maybe this is something for the hack-a-tron in May?

          James Carman added a comment -

          Has anyone looked into RSH for this?

          http://code.google.com/p/reallysimplehistory/

          It's BSD-licensed, so it's ASF license compatible.

          James Carman added a comment -
          James Carman added a comment - - edited

          If you don't want to globally enable it, perhaps you can add it in as a behavior (AjaxBackButtonSupportBehavior)? This could be added to your page?

          Johan Compagner added a comment -

          i will see the patch coming in then...

          James Carman added a comment -

          I don't mind helping, but I'm definitely not the best-qualified Javascript person. Would someone be willing to help point me in the right direction?

          Eelco Hillenius added a comment - - edited

          The difficult part is still how to do versioning on the server side. I don't recall all the details anymore, but Johan, Matej and I got stuck on that part. The JavaScript part by itself is doable (though the problem is that we don't 'own' the UI).

          Martin Sachs added a comment -

          Hi all, this feature is very usefull for all Kind of Web2.0 Pages (especially Portlets). Can someone post some prototypical implementation ? I would like to help with testing and bugfixing.

          Martin Grigorov added a comment -

          Note: See also the descriptions and comments in the linked tickets.

          Igor Vaynberg added a comment -

          i started work on this here: https://github.com/ivaynberg/wicket/tree/ajax-history and the basics are working

          Jordi Deu-Pons added a comment -

          Is there any plan to solve this on Wicket 6?

          Martin Grigorov added a comment -
          Eelco Hillenius added a comment -

          Might as well close it then

          Eelco Hillenius added a comment -

          Doesn't seem like this will ever happen unless it's a big huge itch for someone willing to share a solution. If that day every arrives, we'll just open a new issue aye.


            People

            • Assignee:
              Unassigned
              Reporter:
              Eelco Hillenius
            • Votes:
              24 Vote for this issue
              Watchers:
              25 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development