Uploaded image for project: 'Wicket'
  1. Wicket
  2. WICKET-2606

Enclosure reports incorrect component id for missing components inside the enclosure

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.4.4
    • Fix Version/s: 1.4.5
    • Component/s: wicket
    • Labels:
      None

      Description

      enclosure always reports the id of the component specified as the child as the missing id no matter which component is missing.

      1. testEnclosure.zip
        27 kB
        Douglas Ferguson
      2. testEnclosure2.zip
        157 kB
        Douglas Ferguson

        Activity

        ivaynberg Igor Vaynberg added a comment -

        could not reproduce against 1.4.4, pom points to wicket 1.4.2.

        thedug Douglas Ferguson added a comment -

        This is the one that fails on 1.4.4

        ivaynberg Igor Vaynberg added a comment -

        the correct exception now reads:

        WicketMessage: Could not find child with id: pageRank in the wicket:enclosure

        Root cause:

        org.apache.wicket.WicketRuntimeException: Could not find child with id: pageRank in the wicket:enclosure
        at org.apache.wicket.markup.html.internal.Enclosure.checkChildComponent(Enclosure.java:220)
        at org.apache.wicket.markup.html.internal.Enclosure.ensureAllChildrenPresent(Enclosure.java:262)
        at org.apache.wicket.markup.html.internal.Enclosure.onComponentTagBody(Enclosure.java:169)

        ivaynberg Igor Vaynberg added a comment -

        ps, for future reference: a quickstart is meant to be a minimal demonstration of the bug, not something that has 24+ classes.

        ivaynberg Igor Vaynberg added a comment -

        no, its not, i checked.

        thedug Douglas Ferguson added a comment - - edited

        Ah.. So I can omit items if I know that the enclosure will be hidden?

        That's the way other components work.

        ivaynberg Igor Vaynberg added a comment -

        no, you cannot omit items. see WICKET-2605

        thedug Douglas Ferguson added a comment -

        Ok. Thanks...


          People

          • Assignee:
            ivaynberg Igor Vaynberg
            Reporter:
            thedug Douglas Ferguson
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development