Wicket
  1. Wicket
  2. WICKET-2326

Text on BrowserInfoPage should be customizable

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.4.4, 1.5-M1
    • Component/s: wicket
    • Labels:
      None

      Description

      The text on BrowserInfoPage should be customizable. Currently users gets a flash of the text on the page, and I'd rather they saw a blank page, or at least something that says "Loading..."

      I realise that this is duplicate of the closed issue WICKET-1591, but I have to say, I think you made the wrong call on that.

      In order to change the text of the BrowserInfoPage, I have to override the WebRequestCycle.newClientInfo() method. My problem isn't that this is tricky, but implementing it requires copying a large chunk of code from the WebRequestCycle method, which could potentially change in future versions of the code, making my implementation prone to bugs.

      In think that changing the text of BrowserInfoPage is probably a relatively common requirement, since it looks pretty unprofessional to have a flash of text before the first application page is displayed.

      1. WICKET-2326.patch
        2 kB
        Martin Grigorov

        Activity

        Scott Boyd added a comment -

        If the next page takes a while to load, then the users see this message for long enough to think they should click on the link. It would be better if this page could be customized so we could
        a) change the message
        b) delay display of the message on the page

        Martin Grigorov added a comment -

        Simple patch with a solution.

        Juergen Donnerstag added a comment -

        thanks Martin. Patch applied


          People

          • Assignee:
            Juergen Donnerstag
            Reporter:
            Neil Ferguson
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development