Uploaded image for project: 'Wicket'
  1. Wicket
  2. WICKET-2035

Change naming convention for xml properties files to *.properties.xml instead of *.xml

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Resolved
    • Minor
    • Resolution: Fixed
    • None
    • 1.5-M3
    • wicket
    • None

    Description

      wicket supports xml properties files. Current naming is <Component>.xml. That causes confusion when you want to return xml markup instead of html. There is no simple way to distinguish the content. Of course we could read the file and analyse the content, but changing the convention to *.properties.xml seems to be much simpler. Besides it become more obvious what the file is about (a properties files).

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            mgrigorov Martin Tzvetanov Grigorov
            jdonnerstag Juegen Donnerstag
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment