Wicket
  1. Wicket
  2. WICKET-1792

wicket-1.3.x uses class from java 1.5, therefore doesn't compile on java 1.4 as it should

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.3.5
    • Component/s: wicket
    • Labels:
      None

      Description

      current wicket 1.3.x does not compile with jdk 1.4

      class

      org.apache.wicket.util.crypt.KeyInSessionSunJceCryptFactory

      uses the class

      java.util.UUID

      which exist @since 1.5

      this should be fixed as wicket-1.3 requires a minimum jdk of 1.4

        Activity

        Peter Ertl created issue -
        Hide
        Igor Vaynberg added a comment -

        thanks for fixing johan

        Show
        Igor Vaynberg added a comment - thanks for fixing johan
        Igor Vaynberg made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Johan Compagner [ jcompagner ]
        Resolution Fixed [ 1 ]
        Fix Version/s 1.3.5 [ 12313175 ]
        Peter Ertl made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Johan Compagner
            Reporter:
            Peter Ertl
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development