Uploaded image for project: 'Wicket'
  1. Wicket
  2. WICKET-1737

wicketTester does not find HTML mark-up if custom location is used.

VotersWatch issueWatchersLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Minor
    • Resolution: Fixed
    • 1.3.4, 1.4-M3
    • 1.3.5, 1.4-RC1
    • wicket
    • None

    Description

      If a custom HTML mark-up location is used as described in the ApacheWicket Wiki the wicketTester does not find mark-up to render pages.

      refer to:
      http://cwiki.apache.org/WICKET/control-where-html-files-are-loaded-from.html#ControlwhereHTMLfilesareloadedfrom-InWicket1.3

      Nevertheless running the application with ApacheTomcat 6.0.16 everything renders fine.

      Remark:
      wicketTester has been instanciated using custom test application extended from the application used, overriding newSession for different purpose.

      Attachments

        1. sample1737.zip
          13 kB
          KsTN FK
        2. sample1737-1.3-SNAPSHOT.zip
          22 kB
          Timo Heikki Rantalaiho

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            thrantal Timo Heikki Rantalaiho
            kefker KsTN FK
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment