Wicket
  1. Wicket
  2. WICKET-1623

LinkTree with IndicatingAjaxLink leaks <script> tags

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.3, 1.3.4
    • Fix Version/s: 1.3.6
    • Component/s: wicket-extensions
    • Labels:
      None

      Description

      From mailing list:

      http://markmail.org/message/uhghojcrtq74xm63?q=list:org%2Eapache%2Ewicket%2Eusers

      Extending LinkTree to create IndicatingAjaxLink leaks <script> tags.

      1. linktree-leak.tar.gz
        4 kB
        Philippe Laflamme

        Issue Links

          Activity

          Matej Knopp added a comment -

          Committed fix for 1.3 branch and trunk

          Matej Knopp added a comment -

          I was thinking of leaking of the actual indicator. Okay, the script indeed leaks, it's because of Ajax header contribution

          Philippe Laflamme added a comment -

          Just tried it with 1.3.4 and 1.3-SNAPSHOT: same behaviour as 1.3.3

          If you jetty:run the attached project you can reproduce the issue by simply expanding any node in the tree and inspect the <head> node of the document: <script> tags will appear on every click.

          Matej Knopp added a comment -

          please reopen if this issue is still relevant

          Matej Knopp added a comment -

          Is this still relevant with latest 1.3 branch?

          Philippe Laflamme added a comment -

          A project created with maven-archtype that reproduces the problem.

          Simply execute mvn jetty:run and start clicking away on the tree...


            People

            • Assignee:
              Matej Knopp
              Reporter:
              Philippe Laflamme
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development