Wicket
  1. Wicket
  2. WICKET-1396

Add more explicit exception for NPE in HeaderResponse.java

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.1
    • Fix Version/s: 1.3.2
    • Component/s: None
    • Labels:
      None

      Description

      It took me a bit of debugging to find the cause of my NPE. Having an explicit null check here could save some headaches.

        Activity

        David Leangen added a comment -

        Patch for related issue.


          People

          • Assignee:
            Igor Vaynberg
            Reporter:
            David Leangen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development