Wicket
  1. Wicket
  2. WICKET-131

wicket:fragment tag not handled properly when used with markup inheritance

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0 branch (discontinued)
    • Fix Version/s: 2.0 branch (discontinued)
    • Component/s: wicket
    • Labels:
      None

      Description

      there is a problem when handling wicket:fragment tags that are defined within wicket:extend tags.

      the problem is in InheritedMarkupMarkupLoader:441

      what happens is that first WicketTagIdentified properly assigns tag.id to be the wicket:id defined within the fragment tag
      but then the InheritedMarkupMarkupLoader visits the fragment and resets its tag.id to an autogenerated id

      when rendering occurs markupfragment cannot find the markup of the fragment because its tag.id has been changed

        Activity

        Juergen Donnerstag added a comment -

        remove some left over experimental code. Your test case is now working

        Juergen

        Igor Vaynberg added a comment -

        see FragmentInheritanceTest and InheritedMarkupMarkupLoader:449

        Juergen Donnerstag added a comment -

        I dont see how these things relate. wicket:fragment is not using auto-ids which is what InheritedMarkupMarkupLoader:441 handles. Do you have a junit test case?

        Juergen


          People

          • Assignee:
            Juergen Donnerstag
            Reporter:
            Igor Vaynberg
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development