Wicket
  1. Wicket
  2. WICKET-1239

java.lang.IllegalAccessError when changing AjaxEditableLabel

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.0-rc2, 1.3.0-final
    • Fix Version/s: 1.3.2
    • Component/s: wicket-extensions
    • Labels:
      None
    • Environment:
      Windows XP Pro SP2, Java 1.6.0_03-b05

      Description

      When changing AjaxEditableLabel system throws:

      java.lang.IllegalAccessError: tried to access method
      org.apache.wicket.Component.onModelChanging()V from class
      org.apache.wicket.extensions.ajax.markup.html.AjaxEditableLabel$1
      at
      org.apache.wicket.extensions.ajax.markup.html.AjaxEditableLabel$1.onModelChanging
      (AjaxEditableLabel.java:273)
      at org.apache.wicket.Component.modelChanging(Component.java:2058)
      at org.apache.wicket.Component.setModelObject(Component.java:2823)
      at org.apache.wicket.markup.html.form.FormComponent.updateModel(
      FormComponent.java:992)
      at org.apache.wicket.markup.html.form.FormComponent.processInput(
      FormComponent.java:874)
      [...]

      The probem is in methd:

      protected FormComponent newEditor(MarkupContainer parent, String componentId, IModel model)
      {
      TextField editor = new TextField(componentId, model)
      {
      private static final long serialVersionUID = 1L;

      protected void onModelChanged()

      { super.onModelChanged(); AjaxEditableLabel.this.onModelChanged(); //here is a bug }

      protected void onModelChanging()

      { super.onModelChanging(); AjaxEditableLabel.this.onModelChanging(); //here is a bug }

      };
      editor.setOutputMarkupId(true);
      editor.setVisible(false);
      editor.add(new EditorAjaxBehavior());
      return editor;
      }

      AjaxEditableLabel.this.XXXXXX is not visible.

      Artur

      1. code.java
        2 kB
        Eric Gulatee

        Issue Links

          Activity

          Fredrik Jonsson added a comment -

          Same problem on Mac OS X 10.5.1 Java SE 1.5.0_13-b05-237. But it works on 1.3.0-rc1

          Gerolf Seitz added a comment -

          unfortunately i haven't been able to reproduce this bug on my machine (several tomcat versions, jetty, several java versions),
          but I'm aware that even the examples on wicketstuff.org don't work.

          it would be great if somebody could provide instructions on how i have to setup my environment so i can reproduce this bug.

          Artur Wronski added a comment -

          Use the example code from:
          http://wicketstuff.org/wicket13/ajax/editable-label.1

          When you confirm the label changing the error appears.

          Gerolf Seitz added a comment -

          i have even run the examples on multiple servlet containers, java version.
          so far, i've been unable to reproduce it.

          Per Ejeklint added a comment - - edited

          I think this is a bug in some JRE's, not in the code. An anonymous class should have access to an enclosing class' inherited protected methods - onComponentChanged() and onComponentChanging() in this case - but obviously the JRE things differently.

          A solution/workaround is to declare

          @Override
          protected void onModelChanged()

          { super.onModelChanged(); }

          @Override
          protected void onModelChanging()

          { super.onModelChanging(); }

          in AjaxEditableLabel and all should be fine. At least it works for me on Mac 10.5.1 with Java 1.5.0.

          Gerolf Seitz added a comment -

          that's been my suspicion too.

          unfortunately, the fix you suggested doesn't help much, because we wouldn't even have to override the methods when we're just calling the method in the super class.
          the lines you removed were introduced by WICKET-1097.

          i'll investigate more tonight.

          Gabriel Landon added a comment -

          Don't know if that's helping you, but I've the same problem with jdk1.5.0_10 - tomcat 6.0.10 and eclipse 3.3.
          It's OK with wicket 1.3rc1 and below and doesn't work with wicket 1.3r2 and above.

          Gerolf Seitz added a comment -

          Per, applied your fix, thx

          Gerolf Seitz added a comment -

          after redeploying wicket-examples on wicketstuff.org, the exception is still thrown.

          http://wicketstuff.org/wicket13/ajax/editable-label

          Edvin Syse added a comment -

          I have checked and double-checked. This IS resolved in trunk now. I created a quickstart-project and put the code from the example in
          HomePage.java and HomePage.html. Then I verified that the error was there with 1.3.0. Then I synced wicket against trunk and did a mvn clean
          install in my wicket-folder. Then I changed the pom for the example-project to wicket-version 1.3-SNAPSHOT and did mvn eclipse:eclipse.
          Without any other modification, it then works.

          This is on Linux with jdk1.6.0_04.

          – Edvin

          Gerolf Seitz added a comment -

          finally let's resolve/close this one.
          the build script of our build server still used the 1.3.0-SNAPSHOT versions (rather than the new 1.3-SNAPSHOT versions)
          johan, thanks for fixing that.
          edvin, thanks for double checking again.

          Guilherme Barile added a comment -

          This bug is hapenning on Wicket 1.3.2 running on Glassfish on Mac OS X 10.5.2 (jdk 1.5), full track trace of the error follows

          StandardWrapperValve[WicketApplication]: PWC1406: Servlet.service() for servlet WicketApplication threw exception
          java.lang.IllegalAccessError: tried to access method org.apache.wicket.Component.onModelChanging()V from class org.apache.wicket.extensions.ajax.markup.html.AjaxEditableLabel$1
          at org.apache.wicket.extensions.ajax.markup.html.AjaxEditableLabel$1.onModelChanging(AjaxEditableLabel.java:294)
          at org.apache.wicket.Component.modelChanging(Component.java:2097)
          at org.apache.wicket.Component.setModelObject(Component.java:2863)
          at org.apache.wicket.markup.html.form.FormComponent.updateModel(FormComponent.java:1016)
          at org.apache.wicket.markup.html.form.FormComponent.processInput(FormComponent.java:898)
          at org.apache.wicket.extensions.ajax.markup.html.AjaxEditableLabel$EditorAjaxBehavior.respond(AjaxEditableLabel.java:122)
          at org.apache.wicket.ajax.AbstractDefaultAjaxBehavior.onRequest(AbstractDefaultAjaxBehavior.java:288)
          at org.apache.wicket.request.target.component.listener.BehaviorRequestTarget.processEvents(BehaviorRequestTarget.java:100)
          at org.apache.wicket.request.AbstractRequestCycleProcessor.processEvents(AbstractRequestCycleProcessor.java:90)
          at org.apache.wicket.RequestCycle.processEventsAndRespond(RequestCycle.java:1166)
          at org.apache.wicket.RequestCycle.step(RequestCycle.java:1241)
          at org.apache.wicket.RequestCycle.steps(RequestCycle.java:1316)
          at org.apache.wicket.RequestCycle.request(RequestCycle.java:493)
          at org.apache.wicket.protocol.http.WicketFilter.doGet(WicketFilter.java:354)
          at org.apache.wicket.protocol.http.WicketServlet.doGet(WicketServlet.java:121)
          at javax.servlet.http.HttpServlet.service(HttpServlet.java:718)
          at javax.servlet.http.HttpServlet.service(HttpServlet.java:831)
          at org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:411)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:317)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:198)
          at org.netbeans.modules.web.monitor.server.MonitorFilter.doFilter(MonitorFilter.java:390)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:230)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:198)
          at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:288)
          at org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:271)
          at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:202)
          at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
          at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
          at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:94)
          at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:206)
          at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
          at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
          at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:571)
          at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1080)
          at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:150)
          at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
          at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
          at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:571)
          at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1080)
          at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:270)
          at com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:637)
          at com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:568)
          at com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTask.java:813)
          at com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultReadTask.java:339)
          at com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:261)
          at com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:212)
          at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:265)
          at com.sun.enterprise.web.connector.grizzly.ssl.SSLWorkerThread.run(SSLWorkerThread.java:106)

          Eric Gulatee added a comment - - edited

          This bug is happening on Wicket 1.3.2 running on Tomcat on Mac OS X 10.5.2 (jdk 1.6), full stack trace follows:

          SEVERE: Servlet.service() for servlet HelloWorldApplication threw exception
          java.lang.IllegalAccessError: tried to access method org.apache.wicket.Component.onModelChanging()V from class org.apache.wicket.extensions.ajax.markup.html.AjaxEditableLabel$1
          at org.apache.wicket.extensions.ajax.markup.html.AjaxEditableLabel$1.onModelChanging(AjaxEditableLabel.java:294)
          at org.apache.wicket.Component.modelChanging(Component.java:2097)
          at org.apache.wicket.Component.setModelObject(Component.java:2863)
          at org.apache.wicket.markup.html.form.FormComponent.updateModel(FormComponent.java:1016)
          at org.apache.wicket.markup.html.form.FormComponent.processInput(FormComponent.java:898)
          at org.apache.wicket.extensions.ajax.markup.html.AjaxEditableLabel$EditorAjaxBehavior.respond(AjaxEditableLabel.java:122)
          at org.apache.wicket.ajax.AbstractDefaultAjaxBehavior.onRequest(AbstractDefaultAjaxBehavior.java:288)
          at org.apache.wicket.request.target.component.listener.BehaviorRequestTarget.processEvents(BehaviorRequestTarget.java:100)
          at org.apache.wicket.request.AbstractRequestCycleProcessor.processEvents(AbstractRequestCycleProcessor.java:90)
          at org.apache.wicket.RequestCycle.processEventsAndRespond(RequestCycle.java:1166)
          at org.apache.wicket.RequestCycle.step(RequestCycle.java:1241)
          at org.apache.wicket.RequestCycle.steps(RequestCycle.java:1316)
          at org.apache.wicket.RequestCycle.request(RequestCycle.java:493)
          at org.apache.wicket.protocol.http.WicketFilter.doGet(WicketFilter.java:354)
          at org.apache.wicket.protocol.http.WicketServlet.doGet(WicketServlet.java:121)
          at javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
          at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
          at org.springframework.orm.jpa.support.OpenEntityManagerInViewFilter.doFilterInternal(OpenEntityManagerInViewFilter.java:111)
          at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:75)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
          at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
          at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
          at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
          at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
          at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
          at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:263)
          at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
          at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:584)
          at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
          at java.lang.Thread.run(Thread.java:637)

          Furthermore I extended AjaxEditableLabel and overrode suggested methods. See attached file.

          Johan Compagner added a comment -

          you really dont use 1.3.2 because see what we already do:

          /**

          • Dummy override to fix WICKET-1239
            *
          • @see org.apache.wicket.Component#onModelChanging()
            */
            protected void onModelChanging() { super.onModelChanging(); }

          we already override it. and Line 294 shouldn't call Component.onModelChanging but first that method.

          Eric Gulatee added a comment - - edited

          Johan,

          Thanks. Even though my ivy dependancies were pointing to wicket 1.3, it would see tomcat has older versions deployed.
          It works now after cleaning out stuff.


            People

            • Assignee:
              Unassigned
              Reporter:
              Artur Wronski
            • Votes:
              4 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development