Wicket
  1. Wicket
  2. WICKET-1184

PageSavingThread keeps running after undeploy

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.3.0-rc1
    • Fix Version/s: None
    • Component/s: wicket
    • Labels:
      None
    • Environment:
      Glassfish v2

      Description

      We are deploying our wicket application to Glassfish (v2). After undeploying and deploying a few times the PageSavingThread's of each deploy keeps running.
      I'm not having this problem when deploying the phonebook example (it does not seem tot be triggering that thread)

        Activity

        Francis De Brabandere created issue -
        Francis De Brabandere made changes -
        Field Original Value New Value
        Description We are deploying our wicket application to Glassfish (v2). After undeploying and deploying a few times the PageSavingThread's of each deploy keeps running.
        I'm not having this problem when deploying the phonebook example.
        We are deploying our wicket application to Glassfish (v2). After undeploying and deploying a few times the PageSavingThread's of each deploy keeps running.
        I'm not having this problem when deploying the phonebook example (it does not seem tot be triggering that thread)
        Matej Knopp made changes -
        Assignee Matej Knopp [ knopp ]
        Matej Knopp added a comment -

        Unless I get more information on this I will have to close this as can't reproduce.

        Francis De Brabandere added a comment -

        I won't be able to get more info on this bug as I'm working for a different company now... Since nobody else is watching this bug I suggest you close it.

        Matej Knopp made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]
        Matej Knopp made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Ari Suutari added a comment -

        This bites us too. It is easy to reproduce. Just install tomcat 5.5 or 6.0 and have your wicket-based application .war ready. Open browser and go to http://localhost:8080/manager/html. Find "war file to deploy", enter war path there and click deploy.

        After application has been deployed, check that it works.

        After that, find application from manager list and click "undeploy". It seems to go ok, but if you now take a look at webapps directory, you'll notice that it hasn't been removed. Check whats left: there is at least wicket.jar, for us also wicket-extensions.jar.

        If you take a thread dump from tomcat now, you'll see that there is this thread:

        [2008-01-22 12:36:15] [info] "PageSavingThread-Wicket"
        [2008-01-22 12:36:15] [info] daemon
        [2008-01-22 12:36:15] [info] prio=10 tid=0x0ae79c00
        [2008-01-22 12:36:15] [info] nid=0x1764
        [2008-01-22 12:36:15] [info] waiting on condition
        [2008-01-22 12:36:15] [info] [0x0b50f000..0x0b50fc14]
        [2008-01-22 12:36:15] [info] java.lang.Thread.State: TIMED_WAITING (sleeping)
        [2008-01-22 12:36:15] [info] at java.lang.Thread.sleep(Native Method)
        [2008-01-22 12:36:15] [info] at org.apache.wicket.protocol.http.pagestore.DiskPageStore$PageSavingThread.run(DiskPageStore.java:832)
        [2008-01-22 12:36:15] [info] at java.lang.Thread.run(Unknown Source)

        Obviously when WicketFilter is stopped, it should also take care that also this thread is stopped.

        Frank Bille Jensen added a comment -

        I think it's because the pagesaving thread has been marked for stopping but has not yes stopped before the main threads ends.

        Frank Bille Jensen made changes -
        Resolution Cannot Reproduce [ 5 ]
        Assignee Matej Knopp [ knopp ] Frank Bille Jensen [ frankbille ]
        Status Closed [ 6 ] Reopened [ 4 ]
        Frank Bille Jensen added a comment -

        Fixed this in current trunk. Can you please check if it fixes your problem?

        Frank Bille Jensen made changes -
        Resolution Fixed [ 1 ]
        Fix Version/s 1.3.1 [ 12312500 ]
        Status Reopened [ 4 ] Resolved [ 5 ]
        Ari Suutari added a comment -

        I took a look at the change at DiskPageStore.java you made and it looks about just the same I was going to suggest.
        I'm currently using wicket 1.3 release so I didn't really test this - is there going to be a maintenance release
        for 1.3 ?

        Khlystov Alexandr added a comment -

        problem is still not fixed, I use wicket 1.3.5, and Tomcat 6.0 as application server.

        Igor Vaynberg made changes -
        Resolution Fixed [ 1 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        Igor Vaynberg made changes -
        Assignee Frank Bille Jensen [ frankbille ]
        Igor Vaynberg made changes -
        Fix Version/s 1.3.1 [ 12312500 ]
        Igor Vaynberg added a comment -

        tried to repro with latest 1.4.x and everything worked just fine

        Igor Vaynberg made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Assignee Igor Vaynberg [ ivaynberg ]
        Resolution Cannot Reproduce [ 5 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        58d 9h 3m 1 Matej Knopp 20/Jan/08 20:15
        Resolved Resolved Closed Closed
        7s 1 Matej Knopp 20/Jan/08 20:15
        Closed Closed Reopened Reopened
        2d 1h 43m 1 Frank Bille Jensen 22/Jan/08 21:59
        Resolved Resolved Reopened Reopened
        411d 21h 7m 1 Igor Vaynberg 09/Mar/09 20:16
        Reopened Reopened Resolved Resolved
        315d 11h 24m 2 Igor Vaynberg 19/Jan/10 06:31

          People

          • Assignee:
            Igor Vaynberg
            Reporter:
            Francis De Brabandere
          • Votes:
            2 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development