Whirr
  1. Whirr
  2. WHIRR-420

Document jclouds specific configuration options

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.7.0
    • Component/s: core, documentation
    • Labels:
      None

      Description

      The configuration guide page should include jclouds specific configuration options that are relevant (e.g. number of ssh retries, timeouts etc.)

      http://whirr.apache.org/docs/0.6.0/configuration-guide.html

      1. WHIRR-420.patch
        4 kB
        David Alves
      2. WHIRR-420.patch
        2 kB
        David Alves

        Activity

        Paul Baclace added a comment -

        Thanks for documenting these (with units). I am not aware of any other jclouds settings.

        Andrei Savu added a comment -

        Committed. Thanks David!

        Andrei Savu added a comment -

        +1 nice work

        David Alves added a comment -

        Added the options Adrian suggested the list is now:

        jclouds.compute.timeout.node-terminated
        jclouds.compute.timeout.node-running
        jclouds.compute.timeout.script-complete
        jclouds.compute.timeout.port-open
        jclouds.compute.blacklist-nodes
        jclouds.ssh.retryable-messages
        jclouds.ssh.max-retries
        jclouds.ssh.retry-auth

        Adrian Cole added a comment -

        Thanks for plowing through this!

        some other important properties are

        discussed here: http://groups.google.com/group/jclouds-dev/browse_thread/thread/83e8080dee157394/4e35d64dfb94a4e9?lnk=gst&q=jclouds.ssh.max-retries#4e35d64dfb94a4e9

        and used here: SshjSshClient, JschSshClient

        David Alves added a comment -

        please review!

        David Alves added a comment -

        Added almost all options from ComputeServiceConstants to the site.

        Please let me know if there are other relevant options elsewhere in jclouds.

        Adrian Cole added a comment -

        could be nice to mirror this jira with a jclouds issue to update javadoc.

        Andrei Savu added a comment -

        Thanks Adrian - I will go through that file and write this documentation page.

        Adrian Cole added a comment -

        jclouds ComputeServiceConstants has the properties for things like script timeouts, and could use some documentation
        "jclouds.compute.timeout.script-complete" is in milliseconds and defaults to 10 minutes

        Andrei Savu added a comment -

        Paul can you share some of the options you are using?

        Andrei Savu added a comment -

        How can we increase the following timeout to more than 10 minutes?

        Caused by: org.jclouds.compute.callables.ScriptStillRunningException: time up waiting 600s for running task[RunScriptOnNodeAsInitScriptUsingSshAndBlockUntilComplete{node=[id=us-east-1/i-f1ab7892, providerId=i-f1ab7892, group=zkclustertest, name=zkclustertest-f1ab7892, location=[id=us-east-1d, scope=ZONE, description=us-east-1d, parent=us-east-1, iso3166Codes=[US-VA], metadata={}], uri=null, imageId=us-east-1/ami-ab36fbc2, os=[name=null, family=ubuntu, version=10.04, arch=paravirtual, is64Bit=false, description=099720109477/ebs/ubuntu-images/ubuntu-lucid-10.04-i386-server-20110930], state=RUNNING, loginPort=22, hostname=ip-10-125-10-122, privateAddresses=[10.125.10.122], publicAddresses=[50.17.52.37], hardware=[id=t1.micro, providerId=t1.micro, name=null, processors=[[cores=1.0, speed=1.0]], ram=630, volumes=[[id=vol-9af81ef7, type=SAN, size=null, device=/dev/sda1, durable=true, isBootDevice=true]], supportsImage=And(requiresRootDeviceType(ebs),Or(isWindows(),requiresVirtualizationType(paravirtual)),ALWAYS_TRUE,ALWAYS_TRUE), tags=[]], loginUser=ubuntu, userMetadata={Name=zkclustertest-f1ab7892}, tags=[]], name=setup-andreisavu, runAsRoot=true}] to complete. call get() on this exception to get access to the task in progress
        	at org.jclouds.compute.callables.BlockUntilInitScriptStatusIsZeroThenReturnOutput.get(BlockUntilInitScriptStatusIsZeroThenReturnOutput.java:192)
        	at org.jclouds.compute.callables.RunScriptOnNodeAsInitScriptUsingSshAndBlockUntilComplete.doCall(RunScriptOnNodeAsInitScriptUsingSshAndBlockUntilComplete.java:60)
        	... 8 more
        

          People

          • Assignee:
            David Alves
            Reporter:
            Andrei Savu
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development