Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.1.0
    • Fix Version/s: 0.1.0
    • Component/s: core
    • Labels:
      None

      Description

      There are some API changes which need code changes: http://anyweight.blogspot.com/2010/05/new-jclouds-hardens-cloud-provisioning.html

      1. WHIRR-23.patch
        44 kB
        Adrian Cole
      2. jclouds-compute.log
        41 kB
        Tom White
      3. WHIRR-23.patch
        55 kB
        Tom White
      4. WHIRR-23.patch
        64 kB
        Adrian Cole
      5. WHIRR-23.patch
        65 kB
        Tom White

        Issue Links

          Activity

          Tom White created issue -
          Adrian Cole added a comment -

          patch to update to 1.0-beta-6 and also add log4j files for the integration tests

          Adrian Cole made changes -
          Field Original Value New Value
          Status Open [ 1 ] Patch Available [ 10002 ]
          Affects Version/s 0.1.0 [ 12315111 ]
          Adrian Cole added a comment -

          update to 1.0-beta-6 jclouds and including log4j files to help with integration test debugging.

          please view target/test-data/jclouds-compute.log during tests for provisioning status

          Adrian Cole made changes -
          Attachment WHIRR-23.patch [ 12449899 ]
          Tom White added a comment -

          Thanks for the patch Adrian. I've been trying to run it, but have hit a problem when the scripts are run on the newly-provisioned nodes - see the attached log file. I actually get a similar problem without this patch, which I wasn't seeing before, so I wonder if it's something that changed on the EC2 side. Can you run any of the integration tests (e.g. zookeeper) successfully?

          Tom White made changes -
          Attachment jclouds-compute.log [ 12451557 ]
          Tom White added a comment -

          The integration tests were working for me a couple of weeks ago, but now they don't (with or without this patch, although it's useful to use this patch to diagnose, since you've improved the logging). So can you check whether the zookeeper integration test still works for you? This will allow us to see if it's a problem with my set up, or a more general problem.

          > Hi, Tom.
          >
          > I'll look at the log, but I noticed only zookeeper worked. Since I didn't
          > baseline, I'm not sure if they did before I updated to beta-6.
          >
          > -Adrian

          Tom White added a comment -

          The problem is http://code.google.com/p/jclouds/issues/detail?id=331. If there are no 'stopped' instances running on the EC2 account then this problem does not occur.

          Tom White made changes -
          Link This issue blocks WHIRR-66 [ WHIRR-66 ]
          Tom White added a comment -

          I've now overcome the WHIRR-65 bug (which I've updated for beta-6 in this patch), but Hadoop and Cassandra are not passing for me. I think Hadoop's not working due to changes in how InetAddress is used. Haven't looked at Cassandra yet.

          Tom White made changes -
          Attachment WHIRR-23.patch [ 12451726 ]
          Tom White added a comment -

          Without this patch the AMI that is used is ami-449f772d (099720109477/ubuntu-images/ubuntu-karmic-9.10-i386-server-20100607), with this patch it uses ami-a00ce4c9 (411009282317/RightImage_Ubuntu_9.10_x64_v5.3.0_Beta). HadoopProxy is hardcoded to use the "ubunut" user to start the tunnel - I think this may be where the problem lies.

          Adrian Cole added a comment -

          This patch fixes a few things:

          1. Use InetAddress everywhere, to ensure that hostnames can be written in files as opposed to ip addresses. In the future, we may change this behaviour

          2. lock-in to ubuntu 10.04, as it eases our java installation (for now). Once we get through other issues, we can look at tools for handling multiple operating systems

          Adrian Cole made changes -
          Attachment WHIRR-23.patch [ 12451839 ]
          Tom White added a comment -

          Minor update for the Java install script.

          Tom White made changes -
          Attachment WHIRR-23.patch [ 12451842 ]
          Tom White added a comment -

          I've just committed this. Thanks Adrian!

          Tom White made changes -
          Status Patch Available [ 10002 ] Resolved [ 5 ]
          Assignee Adrian Cole [ adrian@jclouds.org ]
          Resolution Fixed [ 1 ]
          Gavin made changes -
          Link This issue blocks WHIRR-66 [ WHIRR-66 ]
          Gavin made changes -
          Link This issue is depended upon by WHIRR-66 [ WHIRR-66 ]

            People

            • Assignee:
              Adrian Cole
              Reporter:
              Tom White
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development