Wave
  1. Wave
  2. WAVE-336

Wave seems to be saving some wavelets incorrectly

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Environment:
      linux 32bit, Debian Squeeze, Sun Java 6.26-0squeeze1

      Description

      Sometimes when rebooting the server, I'll get something like the following error:

      [java] SEVERE: Error reading delta file for [WaveletName nsb0.net/w+3FN4kqwu2UA/nsb0.net/conv+root] starting at 934908
      [java] java.io.IOException: com.google.protobuf.InvalidProtocolBufferException: Protocol message contained an invalid tag (zero).
      [java] at org.waveprotocol.box.server.persistence.file.FileDeltaCollection.readTransformedWaveletDelta(FileDeltaCollection.java:520)
      [java] at org.waveprotocol.box.server.persistence.file.FileDeltaCollection.readTransformedDeltaFromRecord(FileDeltaCollection.java:435)
      [java] at org.waveprotocol.box.server.persistence.file.FileDeltaCollection.access$100(FileDeltaCollection.java:64)
      [java] at org.waveprotocol.box.server.persistence.file.FileDeltaCollection$1$1.hasNext(FileDeltaCollection.java:308)
      [java] at org.waveprotocol.box.server.persistence.file.DeltaIndex.rebuildIndexFromDeltas(DeltaIndex.java:100)
      [java] at org.waveprotocol.box.server.persistence.file.DeltaIndex.openForCollection(DeltaIndex.java:75)
      [java] at org.waveprotocol.box.server.persistence.file.FileDeltaCollection.open(FileDeltaCollection.java:128)
      [java] at org.waveprotocol.box.server.persistence.file.FileDeltaStore.open(FileDeltaStore.java:69)
      [java] at org.waveprotocol.box.server.persistence.file.FileDeltaStore.lookup(FileDeltaStore.java:101)
      [java] at org.waveprotocol.box.server.persistence.file.FileDeltaStore$3.fetchNext(FileDeltaStore.java:149)
      [java] at org.waveprotocol.box.server.persistence.file.FileDeltaStore$3.hasNext(FileDeltaStore.java:161)
      [java] at org.waveprotocol.box.server.waveserver.WaveMap.loadAllWavelets(WaveMap.java:103)
      [java] at org.waveprotocol.box.server.waveserver.WaveServerImpl.initialize(WaveServerImpl.java:283)
      [java] at org.waveprotocol.box.server.ServerMain.initializeServer(ServerMain.java:211)
      [java] at org.waveprotocol.box.server.ServerMain.run(ServerMain.java:175)
      [java] at org.waveprotocol.box.server.ServerMain.main(ServerMain.java:128)
      [java] Caused by: com.google.protobuf.InvalidProtocolBufferException: Protocol message contained an invalid tag (zero).
      [java] at com.google.protobuf.InvalidProtocolBufferException.invalidTag(InvalidProtocolBufferException.java:68)
      [java] at com.google.protobuf.CodedInputStream.readTag(CodedInputStream.java:90)
      [java] at org.waveprotocol.box.server.persistence.protos.ProtoDeltaStoreData$ProtoTransformedWaveletDelta$Builder.mergeFrom(ProtoDeltaStoreData.java:314)
      [java] at org.waveprotocol.box.server.persistence.protos.ProtoDeltaStoreData$ProtoTransformedWaveletDelta$Builder.mergeFrom(ProtoDeltaStoreData.java:204)
      [java] at com.google.protobuf.AbstractMessage$Builder.mergeFrom(AbstractMessage.java:244)
      [java] at com.google.protobuf.AbstractMessage$Builder.mergeFrom(AbstractMessage.java:182)
      [java] at com.google.protobuf.AbstractMessageLite$Builder.mergeFrom(AbstractMessageLite.java:162)
      [java] at com.google.protobuf.AbstractMessage$Builder.mergeFrom(AbstractMessage.java:661)
      [java] at com.google.protobuf.AbstractMessage$Builder.mergeFrom(AbstractMessage.java:182)
      [java] at com.google.protobuf.AbstractMessageLite$Builder.mergeFrom(AbstractMessageLite.java:153)
      [java] at com.google.protobuf.AbstractMessage$Builder.mergeFrom(AbstractMessage.java:654)
      [java] at org.waveprotocol.box.server.persistence.protos.ProtoDeltaStoreData$ProtoTransformedWaveletDelta.parseFrom(ProtoDeltaStoreData.java:144)
      [java] at org.waveprotocol.box.server.persistence.file.FileDeltaCollection.readTransformedWaveletDelta(FileDeltaCollection.java:518)
      [java] ... 15 more

      And the referenced wave then appears truncated.

      1. broken-wave.zip
        277 kB
        Sohum Banerjea

        Issue Links

          Activity

          Sohum Banerjea added a comment -

          An archive of the _deltas of the wave referenced in the error log.


            People

            • Assignee:
              Unassigned
              Reporter:
              Sohum Banerjea
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development